IMPORTANT BROWSER NEWS


On February 28th 2018, our SHOPJSM.org website will no longer support TLS 1.0 or TLS 1.1 over HTTPS. Many older browsers that do not support TLS 1.2 will no longer work after this date. This change is as a result of the PCI SSC (Payment Card Industry Security Standards Council) and affects all merchants and service providers processing or transmitting credit card data.

WHY ARE WE MAKING THIS CHANGE?

The PCI SSC sets the rules on which technologies are acceptable for use in transmitting cardholder information/data. They have explicitly identified TLS 1.0 & TLS 1.1 as no longer being a strong form of encryption because it is vulnerable to many known attacks.

This is not an action Jimmy Swaggart Ministries is taking alone. EVERY website that transmits or processes credit card information/data will have to make this change. If you are using an insecure or unsupported browser, you will find that you will not be able to access secure websites very soon.

We are pleased to help you ensure compatibility in any way we can. However, please keep in mind that we are not experts in every language or framework and so we aren’t able to test or fix your browser for you.

BROWSER SUPPORT

The following browser versions support TLS 1.2:

• Internet Explorer 11 or higher
• Microsoft Edge
• Apple Safari 7 or higher
• Mozilla Firefox 27 or higher
• Google Chrome 30 or higher

The browser we recommend is Mozilla Firefox.